re = /--\s+\d+\s+--\s+(.*?), US\b/m
str = '[Radius: 4000 mi.] -- 61362 -- Spring Valley, IL, US'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end