$re = '/--\s+\d+\s+--\s+(.*?), US\b/m';
$str = '[Radius: 4000 mi.] -- 61362 -- Spring Valley, IL, US';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);