#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)foo(?:(?!foo|bar).)+bar(?!.*foo.+bar)"
Local $sString = "some text here foo bar word foo bar word foo word bar word foo word bar foo word bar more text here"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")