using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"foo(?:(?!foo|bar).)+bar(?!.*foo.+bar)";
string input = @"some text here foo bar word foo bar word foo word bar word foo word bar foo word bar more text here";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}