const regex = /foo(?:(?!foo|bar).)+bar(?!.*foo.+bar)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('foo(?:(?!foo|bar).)+bar(?!.*foo.+bar)', 'm')
const str = `some text here foo bar word foo bar word foo word bar word foo word bar foo word bar more text here`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}