$re = '/foo(?:(?!foo|bar).)+bar(?!.*foo.+bar)/m';
$str = 'some text here foo bar word foo bar word foo word bar word foo word bar foo word bar more text here';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);