#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[_0-9a-zA-Z-]+\/)?(wp-(?=content|admin|includes).*)"
Local $sString = "wp-content/plugins/example.php" & @CRLF & _
"subsite1/wp-content/plugins/example.php" & @CRLF & _
"subsite2/wp-content/plugins/example.php"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")