import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[_0-9a-zA-Z-]+\\/)?(wp-(?=content|admin|includes).*)";
final String string = "wp-content/plugins/example.php\n"
+ "subsite1/wp-content/plugins/example.php\n"
+ "subsite2/wp-content/plugins/example.php";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}