re = /^(?:[_0-9a-zA-Z-]+\/)?(wp-(?=content|admin|includes).*)/m
str = 'wp-content/plugins/example.php
subsite1/wp-content/plugins/example.php
subsite2/wp-content/plugins/example.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end