const regex = /^(?:[_0-9a-zA-Z-]+\/)?(wp-(?=content|admin|includes).*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[_0-9a-zA-Z-]+\\\/)?(wp-(?=content|admin|includes).*)', 'gm')
const str = `wp-content/plugins/example.php
subsite1/wp-content/plugins/example.php
subsite2/wp-content/plugins/example.php`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}