using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^a-zA-Z\r\n]*[a-zA-Z])(?:[^?@""\s]|""[^@?""\r\n]*"")+$";
string input = @"aaaaa@
111111#
111@
aaaaa?
aaa aaaa
aaaa""
@#1234
aaaa""aaa aaaa""
aaaaa
a11
as@";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}