const regex = new RegExp('^(?=[^a-zA-Z\\r\\n]*[a-zA-Z])(?:[^?@"\\s]|"[^@?"\\r\\n]*")+$', 'gm')
const str = `aaaaa@
111111#
111@
aaaaa?
aaa aaaa
aaaa"
@#1234
aaaa"aaa aaaa"
aaaaa
a11
as@`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}