import re
regex = re.compile(r"^(?=[^a-zA-Z\r\n]*[a-zA-Z])(?:[^?@\"\s]|\"[^@?\"\r\n]*\")+$", flags=re.MULTILINE)
test_str = ("aaaaa@\n"
"111111#\n"
"111@\n"
"aaaaa?\n"
"aaa aaaa\n"
"aaaa\"\n"
"@#1234\n\n"
"aaaa\"aaa aaaa\"\n"
"aaaaa\n"
"a11\n"
"as@")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")