import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^a-zA-Z\\r\\n]*[a-zA-Z])(?:[^?@\"\\s]|\"[^@?\"\\r\\n]*\")+$";
final String string = "aaaaa@\n"
+ "111111#\n"
+ "111@\n"
+ "aaaaa?\n"
+ "aaa aaaa\n"
+ "aaaa\"\n"
+ "@#1234\n\n"
+ "aaaa\"aaa aaaa\"\n"
+ "aaaaa\n"
+ "a11\n"
+ "as@";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}