#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "}(\R).*(?1).*}((?1)|$)"
Local $sString = "está no fim da linha -> }" & @CRLF & _
"qualquer texto, \" blablá etc" & @CRLF & _
"linha } <- não está no final da linha, deve pular" & @CRLF & _
"está no fim da linha, mas tem mais de uma linha entre esse e o primeiro }" & @CRLF & _
"asdasdasasdsaeeeee " & @CRLF & _
"{" & @CRLF & _
"aaaaaa" & @CRLF & _
"adsasdassdasdfff } <- não está no final da linha, não deve pegar" & @CRLF & _
"qualquer texto, \" blablá etc" & @CRLF & _
"asdasdasasdsa" & @CRLF & _
"fim da linha -> }" & @CRLF & _
"apenas uma linha, \", á´bcetc" & @CRLF & _
"esse vai pegar }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")