using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"}(\R).*(?1).*}((?1)|$)";
string input = @"está no fim da linha -> }
qualquer texto, \"" blablá etc
linha } <- não está no final da linha, deve pular
está no fim da linha, mas tem mais de uma linha entre esse e o primeiro }
asdasdasasdsaeeeee
{
aaaaaa
adsasdassdasdfff } <- não está no final da linha, não deve pegar
qualquer texto, \"" blablá etc
asdasdasasdsa
fim da linha -> }
apenas uma linha, \"", á´bcetc
esse vai pegar }";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}