import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\}(\\R).*(?1).*\\}((?1)|$)";
final String string = "está no fim da linha -> }\n"
+ "qualquer texto, \\\" blablá etc\n"
+ "linha } <- não está no final da linha, deve pular\n"
+ "está no fim da linha, mas tem mais de uma linha entre esse e o primeiro }\n"
+ "asdasdasasdsaeeeee \n"
+ "{\n"
+ "aaaaaa\n"
+ "adsasdassdasdfff } <- não está no final da linha, não deve pegar\n"
+ "qualquer texto, \\\" blablá etc\n"
+ "asdasdasasdsa\n"
+ "fim da linha -> }\n"
+ "apenas uma linha, \\\", á´bcetc\n"
+ "esse vai pegar }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}