// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"}(\R).*(?1).*}((?1)|$)").unwrap();
let string = "está no fim da linha -> }
qualquer texto, \\\" blablá etc
linha } <- não está no final da linha, deve pular
está no fim da linha, mas tem mais de uma linha entre esse e o primeiro }
asdasdasasdsaeeeee
{
aaaaaa
adsasdassdasdfff } <- não está no final da linha, não deve pegar
qualquer texto, \\\" blablá etc
asdasdasasdsa
fim da linha -> }
apenas uma linha, \\\", á´bcetc
esse vai pegar }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}