# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\\/]*\[@name='([^']+)']/$1/gm;t' <<< "/content/folder[@name='Dropbox']
/content/folder[@name='whatever']/folder[@name='something else']/report[@name='why']
/content/folder[@name='A/B']
"