use strict;
my $str = '/content/folder[@name=\'Dropbox\']
/content/folder[@name=\'whatever\']/folder[@name=\'something else\']/report[@name=\'why\']
/content/folder[@name=\'A/B\']
';
my $regex = qr/[^\/]*\[@name='([^']+)']/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";