$re = '/[^\/]*\[@name=\'([^\']+)\']/m';
$str = '/content/folder[@name=\'Dropbox\']
/content/folder[@name=\'whatever\']/folder[@name=\'something else\']/report[@name=\'why\']
/content/folder[@name=\'A/B\']
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;