using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\/]*\[@name='([^']+)']";
string substitution = @"$1";
string input = @"/content/folder[@name='Dropbox']
/content/folder[@name='whatever']/folder[@name='something else']/report[@name='why']
/content/folder[@name='A/B']
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}