import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^,]+),?$";
final String string = "Malaysia\n"
+ "1 Street, City 189651, United States\n"
+ "Germany\n"
+ "Block 1 Street 100, City 123456,South Korea\n"
+ " Philippines\n"
+ "999 Road, City HA1 1NU, United Kingdom\n"
+ "United States\n"
+ "City 123456, South Korea\n"
+ "Australia\n"
+ "Munich, Germany\n"
+ "USA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}