$re = '/([^,]+),?$/m';
$str = 'Malaysia
1 Street, City 189651, United States
Germany
Block 1 Street 100, City 123456,South Korea
Philippines
999 Road, City HA1 1NU, United Kingdom
United States
City 123456, South Korea
Australia
Munich, Germany
USA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);