import re
regex = re.compile(r"([^,]+),?$", flags=re.MULTILINE)
test_str = ("Malaysia\n"
"1 Street, City 189651, United States\n"
"Germany\n"
"Block 1 Street 100, City 123456,South Korea\n"
" Philippines\n"
"999 Road, City HA1 1NU, United Kingdom\n"
"United States\n"
"City 123456, South Korea\n"
"Australia\n"
"Munich, Germany\n"
"USA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")