const regex = /([^,]+),?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^,]+),?$', 'gm')
const str = `Malaysia
1 Street, City 189651, United States
Germany
Block 1 Street 100, City 123456,South Korea
Philippines
999 Road, City HA1 1NU, United Kingdom
United States
City 123456, South Korea
Australia
Munich, Germany
USA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}