use strict;
my $str = '34uy_bla_HA_2020-99-22_22-22-22.csv';
my $regex = qr/^([A-Z]|[a-z]|[\d])+_([A-Z]|[a-z]|[\d])+_HA_\d\d\d\d-\d\d-\d\d_\d\d-\d\d-\d\d.csv$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}