$re = '/^([A-Z]|[a-z]|[\d])+_([A-Z]|[a-z]|[\d])+_HA_\d\d\d\d-\d\d-\d\d_\d\d-\d\d-\d\d.csv$/m';
$str = '34uy_bla_HA_2020-99-22_22-22-22.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);