re = /^([A-Z]|[a-z]|[\d])+_([A-Z]|[a-z]|[\d])+_HA_\d\d\d\d-\d\d-\d\d_\d\d-\d\d-\d\d.csv$/m
str = '34uy_bla_HA_2020-99-22_22-22-22.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end