import re
regex = re.compile(r"^([A-Z]|[a-z]|[\d])+_([A-Z]|[a-z]|[\d])+_HA_\d\d\d\d-\d\d-\d\d_\d\d-\d\d-\d\d.csv$", flags=re.MULTILINE)
test_str = "34uy_bla_HA_2020-99-22_22-22-22.csv"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")