$re = '/(point).*(out)/m';
$str = 'I think we have to point certain things out to this man, and after that point some other things out to him too.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);