re = /(point).*(out)/m
str = 'I think we have to point certain things out to this man, and after that point some other things out to him too.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end