import re
regex = re.compile(r"(point).*(out)", flags=re.MULTILINE)
test_str = "I think we have to point certain things out to this man, and after that point some other things out to him too."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")