package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(point).*?(out)`)
var str = `I think we have to point certain things out to this man, and after that point some other things out to him too.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}