import Foundation
let pattern = #"(point).*?(out)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I think we have to point certain things out to this man, and after that point some other things out to him too."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}