const regex = /(point).*?(out)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(point).*?(out)', '')
const str = `I think we have to point certain things out to this man, and after that point some other things out to him too.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}