package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[(\d]
(?:
\b \d{3} \)
(?= .{3,5} \W \b )
\g<spb> \d{3}
|
\B \d{2}
(?= .{4,6} \W \b )
\g<sp> \d{3}
)
\g<sp> \d{4} \b
(?<spb> [ ]{0,2} ){0} # separator after bracket
(?<sp> - [ ]? | [ ] -? [ ]? ){0} # other separators
`)
var str = `(555) 555- 5555
(555) 555 -5555
(555)555 - 5555
(555) 555-5555
(555) 555 - 5555
(555)555- 5555
(555) 555 -5555
555-555-5555
555- 555-5555
555 -555-5555
555-555- 5555
555-555 -5555
555 - 555-5555
555-555 - 5555
555 555 5555
555 - 555 - 5555
555 555 - 5555
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}