$re = '/[(\d]
(?:
\b \d{3} \)
(?= .{3,5} \W \b )
\g<spb> \d{3}
|
\B \d{2}
(?= .{4,6} \W \b )
\g<sp> \d{3}
)
\g<sp> \d{4} \b
(?<spb> [ ]{0,2} ){0} # separator after bracket
(?<sp> - [ ]? | [ ] -? [ ]? ){0} # other separators
/x';
$str = '(555) 555- 5555
(555) 555 -5555
(555)555 - 5555
(555) 555-5555
(555) 555 - 5555
(555)555- 5555
(555) 555 -5555
555-555-5555
555- 555-5555
555 -555-5555
555-555- 5555
555-555 -5555
555 - 555-5555
555-555 - 5555
555 555 5555
555 - 555 - 5555
555 555 - 5555
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);