import re
regex = re.compile(r"""
[(\d]
(?:
\b \d{3} \)
(?= .{3,5} \W \b )
\g<spb> \d{3}
|
\B \d{2}
(?= .{4,6} \W \b )
\g<sp> \d{3}
)
\g<sp> \d{4} \b
(?<spb> [ ]{0,2} ){0} # separator after bracket
(?<sp> - [ ]? | [ ] -? [ ]? ){0} # other separators
""", flags=re.VERBOSE)
test_str = ("(555) 555- 5555\n"
"(555) 555 -5555\n"
"(555)555 - 5555\n"
"(555) 555-5555\n\n"
"(555) 555 - 5555\n"
"(555)555- 5555\n"
"(555) 555 -5555\n\n"
"555-555-5555\n"
"555- 555-5555\n"
"555 -555-5555\n"
"555-555- 5555\n"
"555-555 -5555\n"
"555 - 555-5555\n"
"555-555 - 5555\n"
"555 555 5555\n\n"
"555 - 555 - 5555\n"
"555 555 - 5555\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")