// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)[(\d]
(?:
\b \d{3} \)
(?= .{3,5} \W \b )
\g<spb> \d{3}
|
\B \d{2}
(?= .{4,6} \W \b )
\g<sp> \d{3}
)
\g<sp> \d{4} \b
(?<spb> [ ]{0,2} ){0} # separator after bracket
(?<sp> - [ ]? | [ ] -? [ ]? ){0} # other separators
").unwrap();
let string = "(555) 555- 5555
(555) 555 -5555
(555)555 - 5555
(555) 555-5555
(555) 555 - 5555
(555)555- 5555
(555) 555 -5555
555-555-5555
555- 555-5555
555 -555-5555
555-555- 5555
555-555 -5555
555 - 555-5555
555-555 - 5555
555 555 5555
555 - 555 - 5555
555 555 - 5555
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}