#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[(\d](?:\b\d{3}\)(?=.{3,5}\W\b) {0,2}\d{3}|\B\d{2}(?=.{4,6}\W\b)(?:- ?| -? ?)\d{3})(?:- ?| -? ?)\d{4}\b"
Local $sString = "(555) 555- 5555" & @CRLF & _
"(555) 555 -5555" & @CRLF & _
"(555)555 - 5555" & @CRLF & _
"(555) 555-5555" & @CRLF & _
"" & @CRLF & _
"(555) 555 - 5555" & @CRLF & _
"(555)555- 5555" & @CRLF & _
"(555) 555 -5555" & @CRLF & _
"" & @CRLF & _
"555-555-5555" & @CRLF & _
"555- 555-5555" & @CRLF & _
"555 -555-5555" & @CRLF & _
"555-555- 5555" & @CRLF & _
"555-555 -5555" & @CRLF & _
"555 - 555-5555" & @CRLF & _
"555-555 - 5555" & @CRLF & _
"555 555 5555" & @CRLF & _
"" & @CRLF & _
"555 - 555 - 5555" & @CRLF & _
"555 555 - 5555" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")