$re = '/[(\d](?:\b\d{3}\)(?=.{3,5}\W\b) {0,2}\d{3}|\B\d{2}(?=.{4,6}\W\b)(?:- ?| -? ?)\d{3})(?:- ?| -? ?)\d{4}\b/';
$str = '(555) 555- 5555
(555) 555 -5555
(555)555 - 5555
(555) 555-5555
(555) 555 - 5555
(555)555- 5555
(555) 555 -5555
555-555-5555
555- 555-5555
555 -555-5555
555-555- 5555
555-555 -5555
555 - 555-5555
555-555 - 5555
555 555 5555
555 - 555 - 5555
555 555 - 5555
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);