# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[(\d](?:\b\d{3}\)(?=.{3,5}\W\b) {0,2}\d{3}|\B\d{2}(?=.{4,6}\W\b)(?:- ?| -? ?)\d{3})(?:- ?| -? ?)\d{4}\b"
test_str = ("(555) 555- 5555\n"
"(555) 555 -5555\n"
"(555)555 - 5555\n"
"(555) 555-5555\n\n"
"(555) 555 - 5555\n"
"(555)555- 5555\n"
"(555) 555 -5555\n\n"
"555-555-5555\n"
"555- 555-5555\n"
"555 -555-5555\n"
"555-555- 5555\n"
"555-555 -5555\n"
"555 - 555-5555\n"
"555-555 - 5555\n"
"555 555 5555\n\n"
"555 - 555 - 5555\n"
"555 555 - 5555\n\n\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.