using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[(\d](?:\b\d{3}\)(?=.{3,5}\W\b) {0,2}\d{3}|\B\d{2}(?=.{4,6}\W\b)(?:- ?| -? ?)\d{3})(?:- ?| -? ?)\d{4}\b";
string input = @"(555) 555- 5555
(555) 555 -5555
(555)555 - 5555
(555) 555-5555
(555) 555 - 5555
(555)555- 5555
(555) 555 -5555
555-555-5555
555- 555-5555
555 -555-5555
555-555- 5555
555-555 -5555
555 - 555-5555
555-555 - 5555
555 555 5555
555 - 555 - 5555
555 555 - 5555
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}