import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "doi.+(10\\.\\d{4,6}\\/[^\\\"'&<% \\t\\n\\r\\f\\v]+)";
final String string = "The spontaneous emission rate of semiconductors displays a saturation at high carrier injection\n"
+ "densities due to the filling of the conduction and valence bands. We have carried out time-resolved\n"
+ "experiments, whereby a semiconductor quantum well at room temperature is excited optically by a\n"
+ "short laser pulse and the time decay of its luminescence is measured for different injected carrier\n"
+ "densities. The luminescence decay rate, plotted as a function of injected carrier density, deviates\n"
+ "strongly from the well-known quadratic recombination law, valid at low carrier densities, displaying\n"
+ "a saturation. We have developed a simple analytic theory that accounts for this saturation and can\n"
+ "describe adequately the recombination kinetics of highly excited semiconductor quantum wells.\n"
+ "© 2002 American Institute of Physics.[DOI: 10.1063/1.1519344]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}