// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)doi.+(10\.\d{4,6}\/[^\"'&<% \t\n\r\f\v]+)"#).unwrap();
let string = "The spontaneous emission rate of semiconductors displays a saturation at high carrier injection
densities due to the filling of the conduction and valence bands. We have carried out time-resolved
experiments, whereby a semiconductor quantum well at room temperature is excited optically by a
short laser pulse and the time decay of its luminescence is measured for different injected carrier
densities. The luminescence decay rate, plotted as a function of injected carrier density, deviates
strongly from the well-known quadratic recombination law, valid at low carrier densities, displaying
a saturation. We have developed a simple analytic theory that accounts for this saturation and can
describe adequately the recombination kinetics of highly excited semiconductor quantum wells.
© 2002 American Institute of Physics.[DOI: 10.1063/1.1519344]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}