use strict;
my $str = 'The spontaneous emission rate of semiconductors displays a saturation at high carrier injection
densities due to the filling of the conduction and valence bands. We have carried out time-resolved
experiments, whereby a semiconductor quantum well at room temperature is excited optically by a
short laser pulse and the time decay of its luminescence is measured for different injected carrier
densities. The luminescence decay rate, plotted as a function of injected carrier density, deviates
strongly from the well-known quadratic recombination law, valid at low carrier densities, displaying
a saturation. We have developed a simple analytic theory that accounts for this saturation and can
describe adequately the recombination kinetics of highly excited semiconductor quantum wells.
© 2002 American Institute of Physics.[DOI: 10.1063/1.1519344]';
my $regex = qr/doi.+(10\.\d{4,6}\/[^\"'&<% \t\n\r\f\v]+)/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}