import re
regex = re.compile(r"doi.+(10\.\d{4,6}\/[^\"'&<% \t\n\r\f\v]+)", flags=re.IGNORECASE)
test_str = ("The spontaneous emission rate of semiconductors displays a saturation at high carrier injection\n"
"densities due to the filling of the conduction and valence bands. We have carried out time-resolved\n"
"experiments, whereby a semiconductor quantum well at room temperature is excited optically by a\n"
"short laser pulse and the time decay of its luminescence is measured for different injected carrier\n"
"densities. The luminescence decay rate, plotted as a function of injected carrier density, deviates\n"
"strongly from the well-known quadratic recombination law, valid at low carrier densities, displaying\n"
"a saturation. We have developed a simple analytic theory that accounts for this saturation and can\n"
"describe adequately the recombination kinetics of highly excited semiconductor quantum wells.\n"
"© 2002 American Institute of Physics.[DOI: 10.1063/1.1519344]")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")