const regex = /\b(?:3|4|5|6|7|8|9|10|11|12|13|14|15|16|17|18|19|20|21|47|45|68|100|104),?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:3|4|5|6|7|8|9|10|11|12|13|14|15|16|17|18|19|20|21|47|45|68|100|104),?', 'gm')
const str = `4,6,7,28,9,8,12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}