use strict;
my $str = '4,6,7,28,9,8,12';
my $regex = qr/\b(?:3|4|5|6|7|8|9|10|11|12|13|14|15|16|17|18|19|20|21|47|45|68|100|104),?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}